The new version of our Android app has now been approved by Google and released on the Google Play Store. This update resolves the issue where some Android users were seeing anonymised data instead of their own after logging in. Throughout the incident, no personal or sensitive user data was ever compromised, at risk or exposed.
Details
Affected Platform: Android only - iOS users were not affected.
Root Cause: A misconfiguration in our last app deployment led some users to see anonymised, developer-environment data.
Resolution: A corrected version of the Android app has been published to the Google Play Store.
User Impact: Only a small subset of Android users were affected. These users are now able to update to the latest version and regain normal functionality.
Current Status
The updated Android app is available for download on the Google Play Store and we have restored normal operations, and end users are no longer affected.
Next Steps
If you experience any further issues, please update your app to the latest version and contact our support team if you need any help.
Thank you for your patience and understanding. If you have any questions or concerns regarding this incident, please reach out to our support team.
Posted Jan 25, 2025 - 13:23 GMT
Identified
Incident Summary
On the afternoon of January 22nd, we released an update to our Android app on the Google Play Store.
Shortly afterward, we received a report (on January 23rd) that some Android users were seeing anonymised data in their app rather than their own data.
Importantly, no actual user data was at risk or compromised; the information displayed was via a purposefully anonymised developer environment. This issue did not affect iOS users.
Actions Taken
Engineers identified and resolved the root cause of this display issue earlier today (24/01/25).
A corrected version of the Android app has been submitted to the Google Play Store and is currently awaiting Google's review. Typically, reviews are completed and releases approved within 24 hours.
As an interim measure, we have taken our staging environment offline to prevent further confusion. Affected users may see a "network error" message when attempting to login instead of anonymised data while we await the new app release being approved by Google.
User Impact
A small number of users have so far reported seeing anonymised data. We are currently establishing total number of users affected.
No personal or sensitive information from any user account was exposed or at risk at any time.
Next Steps
We will provide another update once the new Android release is approved and live on the Google Play Store.
We apologise for any confusion this may have caused and appreciate your patience and understanding as we work to fully resolve the issue. If you have any questions or concerns, please reach out to our support team.
Posted Jan 24, 2025 - 13:10 GMT
This incident affected: Mobile App (Android & iOS).