Issue related to sending emails from Pandle

Incident Report for Pandle

Investigating

We are investigating an issue where emails aren't being sent from Pandle.
Posted Sep 14, 2026 - 12:13 BST
This incident affects: Email Delivery.