The degraded performance issues have been resolved
Posted Jan 29, 2026 - 11:29 GMT
Identified
The issue has been identified, and we are currently implementing a fix.
Posted Jan 29, 2026 - 10:18 GMT
Investigating
We’re currently investigating reports of degraded performance and discrepancies in the cash flow report. The team is actively working on this, and updates will be posted here as they become available.
Posted Jan 27, 2026 - 20:09 GMT
This incident affected: Web App (my.pandle.co.uk).