Issue with sending emails from Pandle

Incident Report for Pandle

Identified

Pandle is currently experiencing an issue with the sending of all emails, including invoices and payment reminders. We apologise for the inconvenience and are working hard to resolve the matter.
Posted Mar 11, 2026 - 10:35 GMT
This incident affects: Email Delivery.